| Home | Trees | Indices | Help |
|---|
|
|
Helper package for handling TLS extensions encountered in ClientHello and ServerHello messages.
|
|||
|
ClientCertTypeExtension This class handles the Certificate Type extension (variant sent by client) defined in RFC 6091. |
|||
|
ECPointFormatsExtension Client side list of supported ECC point formats. |
|||
|
NPNExtension This class handles the unofficial Next Protocol Negotiation TLS extension. |
|||
|
SNIExtension Class for handling Server Name Indication (server_name) extension from RFC 4366. |
|||
|
SRPExtension This class handles the Secure Remote Password protocol TLS extension defined in RFC 5054. |
|||
|
ServerCertTypeExtension This class handles the Certificate Type extension (variant sent by server) defined in RFC 6091. |
|||
|
SignatureAlgorithmsExtension Client side list of supported signature algorithms. |
|||
|
SupportedGroupsExtension Client side list of supported groups of (EC)DHE key exchage. |
|||
|
TACKExtension This class handles the server side TACK extension (see draft-perrin-tls-tack-02). |
|||
|
TLSExtension This class handles the generic information about TLS extensions used by both sides of connection in Client Hello and Server Hello messages. |
|||
|
|||
__package__ =
|
|||
| Home | Trees | Indices | Help |
|---|
| Generated by Epydoc 3.0.1 on Thu Nov 5 14:25:05 2015 | http://epydoc.sourceforge.net |